Matisse



Summary

input/output
generation of the computational grid

Back to manual summary



Introduction
MATISSE is one of the mesh generator which is available for Telemac modelling system. This program generates two files from the bottom topography file : The geometry file, which is the co-ordinates of the computational grid and the boundary conditions file, which is the definition of the boundary conditions.
back to summary

1. Input / output
Input : the bottom topography file
It is the file which contains the co-ordinates of the points of the study domain. This points could be placed random. The format of this file is different according to the program that you have used for digitalise the data. In our case, the file are always digitalize with SINUSX. The structure of the file is as the following : three columns which correspond to x, y and z. The extension of this file must be  name_of_file.sx
back to summary

2. Generation of the computational grid
2.1. Work preparation
To run MATISSE, type in the current dos control window the command   > matisse
Then, the graphic interface of MATISSE appears :



 


The menu : Projet Edition Donnees Action
The mode : Bathymetrie Lignes geo M.N.T Maillage Conditions aux lim

 
back to summary
2.2 creation of the project
- click on Projet -> Nouveau.
- In the current box, click on projet vide and selectionne the name of the current directory, that is to say ./
- Type the name of the project and click on Valider.
- A window opening where you can choose the precision. For example, 1.e.-03.Then, click on Valider.

 
2.3. Import the bottom topography datas
- In the menu, click on Données -> Importer lignes/points
- Choose the bottom file, for example bathy.sx
- Choose the right format of your file. (For example, SINUSX if the bottom file was create by this program)

 
2.4. Vizualize the topography
Click in the main window and click on V letter. The topography of the domain appears. For example, in our case, we obtain :



 


2.5. Create the boundary of the domain and add simple geometry
This part permits to create the study domain, that is to say the boundary, and to create some simple geometry, for example the pile of a bridge.
- Click on the mode lignes geo
Phase 1 creation of amont and aval boundary
- Definition of the amont boundary
- In the menu, click on Données -> Créer ligne
- Click on two points in order to create a line which close the domain. Be carefull because this line must be in the interior of the       bottom points.
        - Valider your selection by clicking on the right button of the mouse.
        - Put the touch Echap in order to desactivate the selection
        - Click on the two points of the line
        - In the Menu, click on Action -> Définir points durs. Selection dur and valider
       (a "point dur" correspond to a solid part of the domain and must be an angle point)
        - Put the Echap touch in order to desactivate the selection
        - Selection the line with the mouse
- Menu : Action ->projeter ligne. This operation permits to create automaticly points along the line, and allows to represent correctly the bottom topograpy at this boundary.
- Achieve the same operation for the aval boundary
At this point, you obtain this configuration :


We can see the "point dur" in yellow
Phase 2 : Connecting the differents boundary in order to create a close domain.
- Selection with the mouse the points A and B.
- Menu : Action -> Connecter
Achieve the same operation for C and D
- All the points at the angle must be redefine as "point dur"
We have thus define a close contour where all the angle points are defined as point dur. The final operation is to indicate that this domain is the computation domain
- Click on the contour
- Edition -> Editer type de ligne and choose contour
We obtain the following configuration :



 
Notice that the "points durs" are in yellow.
2.6. Creation of the criterias
At this stage, we have define a contour. Now, we have to define the number of cells that we want to have in this domain. In Telemac, this stage is called creation of the criteria.
6.1 Definition of a criteria

 



 

Matisse generate triangular mesh. A "critère" is a numerical information associated to each point of the domain. Matisse use this information as the mesh lenght to create at this point.
Therefore, the first criteria, which appears under the box "1er operande", is the criteria "bathymetrie", which correspond to the bottom point
In this section, we give one method in order to create the mesh.
In the box "1er operande", choose Bathymetrie
In the box "Operateur", choose the value constante
In the box Resultat, type the name of the criteria
In the box "2eme operande", enter the lenght of the mesh
Then click on appliquer
2.7. mesh generation
Click on the mode maillage
Choose the criteria
A window give the estimate number of points. This number is very important in order to fixed the size of the table in the FORTRAN FILE, therefore you should write it.
In order to generate the geometry file, In the menu : Projet -> Générer fichier TELEMAC (give a noun and Valider)
You obtain this configuration :
back to summary
2.8. Boudary condition generation file
At this stage, click on the mode "condition aux limites"
The creation of the boundary condition file can be divided in three stage.
Firstly, creation of the "groupe", which correspond to a group of points which have the same boundary conditions.
Secondly, definition of the "entité", which correspond to a boundary condition type.
Finally, the connexion of "groupe" to "entité".
a. creation of the "groupe"
Click on : Editions --> Sélectionner enveloppe
With the left button of the mouse, select a contour which encompass all the point of the left frontier for example, with the angle points too. Valide your selection with the right button of the mouse.
All the points of the group must be in red.
Click on : Données --> Créer groupe , enter a name for this "groupe" and choose a color. Then, click on Valider
Achieve the same operation for the other boundary.
b. creation of the "entité"
Click on Données --> Créer entité
You obtain the following window. In this window, you can define a boundary condition type.

Type a name for the "entité", and define the conditions for water height (H), velocity (U,V) and (T)
c. connexion
Finally, you have to connect "groupe" to "entité"
Click on Actions --> Associer groupe-entité
Select a "groupe" and the corresponding "entité" and click on appliquer
Finally, you can create the boundary conditions file.
Click on Projet -- > Générer fichier conlim
back to summary